Degraded Service 10/20/25

Incident Report for Kipsu

Resolved

The issue causing messaging delays has been resolved. All systems are now fully operational.
Posted Oct 21, 2025 - 07:57 CDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 18:55 CDT

Update

We are continuing to see improvement in message delivery times. Users may still experience delays with inbound messages and, in some cases, slight delays with outbound messaging. Recovery progress is ongoing and performance continues to improve.
Posted Oct 20, 2025 - 16:23 CDT

Monitoring

We are beginning to see improvement in message delivery times. Users may still experience delays with inbound messages and, in some cases, slight delays with outbound messaging. Recovery progress is ongoing and performance continues to improve.
Posted Oct 20, 2025 - 14:45 CDT

Update

Kipsu Engage is currently facing a service disruption with our third party partners that is preventing inbound messaging. Outbound messaging will still function with a slight delay. We will provide further information on this situation as we hear more from our partners.
Posted Oct 20, 2025 - 12:43 CDT

Update

We are still experiencing service disruption related to an external provider issue. Our team is all hands on deck working to mitigate these issues. Users may still experience delays with inbound messaging and delays in loading the Kipsu application as our systems work to recover. We will continue to provide updates as more information becomes available.
Posted Oct 20, 2025 - 10:38 CDT

Update

We are continuing to work toward full resolution. Kipsu performance is improving; however, some users may still experience delays with inbound messaging and delays in loading the Kipsu dashboard as our systems recover.
Posted Oct 20, 2025 - 09:04 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 07:06 CDT

Investigating

Kipsu is investigating a current system service disruption due to a third party vendor. We will provide additional updates as more information becomes available.
Posted Oct 20, 2025 - 06:34 CDT
This incident affected: Kipsu Web Application, Kipsu Digital Asset Manager, Kipsu Mobile Application, API, and Kipsu Connector.