Kipsu Service Disruption 6/23/2026

Incident Report for Kipsu

Resolved

We have identified the root cause of the incident. The Kipsu Web Application service is fully restored, and Kipsu is functioning normally.
Posted Jun 23, 2026 - 15:25 CDT

Investigating

We are currently investigating an issue causing users to encounter an error logging into Kipsu. Further information will be provided here.
Posted Jun 23, 2026 - 14:58 CDT
This incident affected: Kipsu Web Application, Kipsu Digital Asset Manager, Kipsu Mobile Application, API, Facebook Messenger Integration, Live Web Chat, and Kipsu Connector.