Users Receiving 'Account Not Found' Error
Incident Report for Kipsu
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 16:39 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2024 - 16:21 CDT
Identified
We have identified the issue and are developing a solution to restore normal service.
Posted Mar 26, 2024 - 15:35 CDT
This incident affected: Kipsu Web Application and Kipsu Mobile Application.