Some Inbound Messages Experiencing Duplications and Delivery Delays
Incident Report for Kipsu
Resolved
After continuing to monitor the success of the release yesterday, Kipsu Engineers believe this issue has been resolved. We apologize for the inconvenience that this problem caused you and your team. We are so very sorry for the difficult spot this put you in with your guests as well, especially during a very busy weekend. Thank you for your patience as we worked as quickly as possible to resolve this issue. Please reach out to support@kipsu.com with any questions.
Posted Feb 15, 2021 - 10:42 CST
Update
Per the last update, the Kipsu Engineers believe they have successfully released a fix for the issues of message delays and duplications early this morning. We will need to continue to monitor the situation to make sure we have completely resolved the issue. Since the release to our messaging service was completed today, you may experience additional message duplicates as our messaging services finishes going through the queue of inbound messages that was duplicating. We are so very sorry for all the inconveniences that this problem caused. We really appreciate your patience and understanding as we worked as quickly as we could to get these issues resolved.
Posted Feb 14, 2021 - 14:01 CST
Monitoring
At this time Kipsu Engineers believe they have successfully released a fix for the issues of message delays and duplications. We will need to continue to monitor the situation over the coming hours to make sure we have completely resolved the issue. Since the release to our messaging service was just completed, you could continue to experience additional message duplicates over the next couple of hours as our messaging services finishes going through the queue of inbound messages that was duplicating. We are so very sorry for all the inconveniences that this problem caused. We really appreciate your patience and understanding as we worked as quickly as we could to get these issues resolved.
Posted Feb 14, 2021 - 05:29 CST
Update
At this time our team has deployed one of the solutions to help with this issue. Unfortunately, it is not resolving the whole problem, so our team is continuing to work on additional steps to resolve this issue. Due to the many moving parts to our messaging service, there are many pieces at work to resolve this problem accurately and correctly. We are very sorry for the time it is taking and please know we are working as quickly as we can to get this frustrating issue resolved for our customers. We will continue to provide another update in the next couple of hours at the latest. We are so apologetic for the impact this continues to have.
Posted Feb 14, 2021 - 04:14 CST
Update
Our team is still working very hard on deploying multiple solutions to these issues. There are many moving parts to our messaging service, which is why it is taking additional time to work to resolve this problem accurately and correctly. Please know we have all hands on deck on this issue. We will continue to provide another update in the next couple of hours at the latest. We are so apologetic for the impact this continues to have on you, your team, and your customers.
Posted Feb 14, 2021 - 00:34 CST
Update
Kipsu Engineers are continuing to work on a solution, to this issue, from multiple angles. We are currently working to deploy different strategies to our messaging service to help to solve this difficult issue. We apologize for the continued frustration and burden this adds to your team. We will provide another update by 12am CST.
Posted Feb 13, 2021 - 22:40 CST
Update
Kipsu Engineers are continuing to work on a solution to this issue. Please know this is a top priority to us and we are doing everything we can to resolve this as quickly as possible. Also, during our continued investigation over the last hour, we have found that this issue now includes message delivery failures for some outbound and inbound messages. Please note this would not be impacting all messages. We are so very sorry for the inconvenience and frustrations this causes your team. We will provide another update in an hour.
Posted Feb 13, 2021 - 20:39 CST
Update
Kipsu Engineers are continuing to work on a solution to this issue with one of our messaging suppliers causing inbound messages to experience duplications and a delivery delay of up to 10 minutes. Please know this is a top priority to resolve and note that this is not affecting all inbound messages. We will provide additional updates within the next 1 hour. We apologize for this inconvenience.
Posted Feb 13, 2021 - 18:55 CST
Identified
Kipsu Engineers have been made aware of a system issue with one of our suppliers causing inbound messages to experience duplications and a delivery delay of up to 10 minutes. Please note that this is not affecting all inbound messages at this time. Please know this would have only impacted some Kipsu customers. We will provide additional updates as more information becomes available. We apologize for any inconvenience
Posted Feb 13, 2021 - 16:21 CST
This incident affected: API.