Digital Asset Loading Issue

Incident Report for Kipsu

Resolved

We have resolved the performance degradation previously noted with Digital Assets. After a thorough investigation, we have confirmed that this was a back-end processing issue that did not impact the delivery or visibility of digital attachments for users or guests. All systems are operating normally.
Posted Mar 17, 2026 - 10:12 CDT

Investigating

We are currently investigating reports of degraded performance within Digital Assets. Users/guests may experience intermittent failures when attempting to view or download digital attachments in Kipsu messages.

Our engineering team is on the case, and we’ll provide another update as soon as we have more information.
Posted Mar 17, 2026 - 08:57 CDT
This incident affected: Kipsu Digital Asset Manager.